Jump to content


- - - - -

Перестала открываться главная страница 500


9 replies to this topic

#1 slon (guest)

slon (guest)
  • Guests

Posted 09 December 2013 - 11:30 AM

День добрый.

Версия  Version: 1.6.c [9th of December 2013]

Сайт заведен на русском, в настройках прописан через пуни.

После накатывания openshop админка работает, главная выдает ошибка 500.


  • 0

#2 slon362

slon362

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 09 December 2013 - 11:36 AM

Solution: create empty file called [OpenShop_disabled]
at [vqmod/xml/OpenShop] folder.
This will disable OpenShop and give you access to the shop

.
 
не помогает, даже в админке не отключает.


  • 0

#3 slon362

slon362

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 09 December 2013 - 11:57 AM

В логах ругается на корзину почемуто:

2013/12/09 11:07:14 [error] 9883#0: *7483 FastCGI sent in stderr: "PHP message: PHP Parse error:  syntax error, unexpected '=', expecting ')' in /var/www/domen/vqmod/vqcache/vq2-system_library_cart.php on line 318" while reading response header from upstream, client: 217.15.203.217, server: domen.com, request: "GET / HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "domen.com", referrer: "http://domen.com

Вот что в строке: 

public function add($product_id, $qty = 1, $option, $profile_id = '' = '') {

  • 0

#4 MaxD

MaxD

    Administrator

  • Administrators
  • 715 posts

Posted 09 December 2013 - 06:31 PM

А накатывал на предыдущий OpenShop? Перед этим надо было удалить содержимое vqmod/xml/OpenShop


  • 0

#5 Guest (guest)

Guest (guest)
  • Guests

Posted 09 December 2013 - 07:13 PM

На чистый опенкарт. В настройках отключил мод, главная тутже открылась.


  • 0

#6 MaxD

MaxD

    Administrator

  • Administrators
  • 715 posts

Posted 13 December 2013 - 11:50 PM

На чистый OpenCart какой версии? Почему не использовали OpenShop-Installer?


  • 0

#7 Guest (guest)

Guest (guest)
  • Guests

Posted 14 January 2014 - 05:56 PM

у меня аналогичная проблема кстати. Чисты инсталлер не работает, ввиду что на моей конфигурации nginx начинает скачивать файл сразу в браузер.


  • 0

#8 slon362

slon362

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 14 January 2014 - 06:13 PM

ошибку в строке 318 поборол, попробуйте заменить на

    public function add($product_id, $qty = 1, $option, $profile_id = '') {

по факту удаляется лишнее =" как я понял.

У меня сейчас другая проблема, после починки главной этим методом перестал работать слайдшоу, в пути добавляется token: и не отображается картинка openshop в админке.

2.94.115.27 - - [14/Jan/2014:18:02:50 +0000] "GET /admin/view/image/OpenShop_home.png HTTP/1.1" 200 2861 "http://domen/admin/i...8724d9b9e004a02" "Opera/9.80 (Windows NT 6.1; WOW64) Presto/2.12.388 Version/12.16"


  • 0

#9 MaxD

MaxD

    Administrator

  • Administrators
  • 715 posts

Posted 15 January 2014 - 05:02 PM

у меня аналогичная проблема кстати. Чисты инсталлер не работает, ввиду что на моей конфигурации nginx начинает скачивать файл сразу в браузер.

Киньте доступ, охота глянуть


  • 0

#10 slon362

slon362

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 15 January 2014 - 05:27 PM

Кинул, уже глянули )))


  • 0



Reply to this topic



  



 

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Community Skin by Fredson Nunes Junior